Opened 8 years ago

Closed 8 years ago

#192 closed defect (fixed)

Default setting for 6in4 tunnel should not be defaultroute=0, and there is no Luci interface for seeing that option

Reported by: reporter Owned by: jow
Priority: major Milestone:
Component: LuCI Applications Keywords:
Cc: hannu.nyman@…

Description

When creating a new interface with Luci 0.10 (and trunk, I guess) and selecting '6in4' tunnel as the interface type, Luci sets explicitly defaultroute=0 for that tunnel. And that prevents the usage of the tunnel for IPv6 connectivity with outside network. Most people creating a 6in4 tunnel interface are going to use that tunnel for their IPv6 connectivity, so explicitly disabling that as defaultroute is counterproductive.

Ticket #43 was about a similar issue with PPP(oe) interfaces, and r4001 and r4113 were fixing that.

The problem is that Luci explicitly creates the config value "defaultroute=0" for that interface. Looks like there is no need to set that as 1 for 6in4, just omitting the option for 6in4 interfaces is fine and makes my tunnel to work.

The problem is made difficult for users by the fact that there seems to be no Luci access to either "defaultroute" or "peerdns" options, which both are set by creating the interface and going to its options.

Step to reproduce the config.
1) Luci / Network / Interfaces: select " Add new interface" button
2) set name as "example", do not set other options. select "Submit" to create the new interface. (At this point there are "5 Unsaved changes".)
3a) You end up in the new interface's settings page. Without setting any options, just press "Save". The value of unsaved changes jumps to 8, and 'network.example.defaultroute=0' is among the autoamtically generated 3 options.
3b) alternatively, set interface type as '6in4' before pressing 'Save'. It still sets the defaultroute=0 option, and there seems to be no way to remove that setting through Luci.

As step 3a shows, the current logic seems to be to force defaultroute=0 for all interfaces.

Please allow users access to that option through Luci user interface, or at least disable creating that option for 6in4 interfaces (default for 6in4 tunnels should probably be 1).

Change History (4)

comment:1 Changed 8 years ago by reporter

Additional note:
verified from https://dev.openwrt.org/browser/trunk/package/6in4/files/6in4.sh

The default for 6in4 tunnels is '1':

        local defaultroute
	        config_get_bool defaultroute "$cfg" defaultroute 1

So, setting it to 0 is not what is intended by package creators.

comment:2 Changed 8 years ago by jow

  • Owner set to jow
  • Status changed from new to accepted

comment:3 Changed 8 years ago by jow

This behaviour should be fixed with r6821 and r6822 but it needs a bit of testing yet so I won't merge it into the 0.10 branch immediately.

comment:4 Changed 8 years ago by jow

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.